En la versión de Velneo 7.17 has de tener en cuenta la siguiente información importante.

Se han actualizado multitud de librerías necesarias para el correcto funcionamiento de Velneo V7 y esto conlleva unos nuevos requisitos en cuanto a librerías de sistema. Puedes ver un completo artículo sobre esto en nuestra base de conocimiento, dentro del Centro de Soporte de Velneo. A modo de resumen te podemos decir:

  • En Windows se soportan todos los sistemas operativos desde Windows XP, aunque no recomendamos su uso debido a la discontinuidad por parte de Microsoft de este sistema, recomendamos la sustitución por un sistema más moderno lo antes posible.
  • En Mac la versión mínima necesaria es OSX Lion (10.7)
  • En Linux, depende de la distribución. Por ejemplo en Ubuntu como mínimo la versión 12.04 y hay que añadir algunas librerías adicionales, según si es una versión Desktop o LTS. (GLibc 2.15 y superiores)

Recuerda, más información en nuestra base de conocimiento dentro del Centro de Soporte de Velneo.

Con esta versión desaparecen el componente Velneo vWebclient, como ya anunciamos con anterioridad por la falta de apoyo a NPAPI.

En esta nueva versión, además de los estilos propios de cada sistema, aparece un nuevo estilo, el estilo Fusión, mejorado y optimizado para todos los sistemas, que sustituye a los anteriores estilos, ya obsoletos. Este estilo nos permite homogeneizar el aspecto de nuestra aplicación de forma independiente al sistema operativo y su estilo, si así lo queremos.

Con la versión se han actualizado también librerías de sistema como la de configuración de estándares de idioma. Si configuras un idioma en concreto, esa configuración la toma del estándar ICU que reúne las configuraciones estándar de idioma. La Real Academia indica que se debe usar el espacio como carácter de separador de miles, así que este extremo está recogido en el estándar ICU. Para que se tome la configuración del sistema, la que tienes definida en el panel de control del sistema operativo, debes escoger la opción Idioma del sistema. Así, debería mostrarte el separador de miles con el punto como tienes definido, o la configuración que te interese.

El requerimiento de usar file:/// para indicar URL’s en disco, que viene de atrás y no sólo para este caso,  se da la circunstancia de que en determinados sistemas operativos funcionaba aunque no se especificara el esquema, con lo que se tenía la impresión de que no era necesario, cuando lo realmente lo es. En esta versión debemos asegurarnos de que se indica siempre.

Hemos detectado que algunos sistemas operativos Windows XP no permiten al instalador instalar todas las librerías necesarias para el correcto funcionamiento de la plataforma. Se ha actualizado el instalador de Windows para evitar esta incidencia (muestra la versión 7.17.0.13169). En cualquier caso, copiar la carpeta plugins que encontramos en la carpeta de instalación de Velneo dentro de la carpeta Velneo-vUpdater que se encuentra dentro, permite arreglar las instalaciones ya realizadas. De todas formas, reiteramos nuestra recomendación de actualizar este sistema operativo ya obsoleto.

Hemos detectado incidencias con plugins NPAPI dentro del control HTML (por ejemplo Acrobat Reader PDF plugin, Acrobat Flash plugin) que impiden una correcta visualización.

Hemos detectado una incidencia en la indexación de contenido html externo con elementos no compatibles en campos objeto texto enriquecido.

Hemos detectado un cambio de comportamiento en el pintado de formularios que se han definido con un tamaño superior al soportado por la pantalla en modo vista, que requiere redimensionar el tamaño de los formularios y subformularios a un tamaño menor que sí soporte la pantalla.

No es posible usar el comando de instrucción “Ejecutar documento” en 3º plano, debemos sustituirlo por el comando de instrucción “Ejecutar comando del sistema” indicando como parámetro el ejecutable y el fichero que ha de abrir.

Velneo V7 7.17 aunque permite conectarse con versiones anteriores, es recomendable actualizar tanto el servidor como los clientes antes de operar con las aplicaciones, para garantizar el correcto funcionamiento. El uso con versiones anteriores puede provocar comportamientos no esperados.

Las soluciones y proyectos serán migrados a la nueva versión de forma transparente y sin realizar ninguna tarea de mantenimiento.